perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steve Hay" <Steve...@planit.com>
Subject RE: Problems building mod_perl-2.0.3 on Win32 with VC8
Date Wed, 22 Aug 2007 13:09:43 GMT
Steve Hay wrote:
> Randy Kobes wrote:
>> On Wed, 22 Aug 2007, Steve Hay wrote:
>>> I then thought that I'd try building the latest 2.2.x snapshot
>>> instead (httpd_20070822041638.tar.gz), just in case I've missed some
>>> other relevant changes for building with VC8. [...]
>>> 
>>> Sure enough, ap_requires() has been removed from server/core.c in
>>> the current httpd source. I tried mod_perl from svn, but that still
>>> calls ap_requires().
>> 
>> This is strange - the removal of ap_requires() from
>> server/core.c happened 19 months ago, so mp2 should
>> be aware of that. If I'm following things correctly
>> in the mp2 sources, though, it should be defined;
>> mp2\WrapXS\Apache2\Access\Access.xs defines
>> ap_requires() in terms of mpxs_ap_requires(), which
>> is defined in mp2\xs\Apache2\Access\Apache2__Access.h.
>> So it sounds like this is an internal mp2 problem;
>> could that also be related to manifest files?
> 
> I hadn't noticed that ap_requires() disappeared so long ago. I just
> saw that it was not in server/core.c in the snapshot, but is in
> httpd-2.2.4's source, so I assumed it was a recent change. I'll have a
> harder squint at what's going on.
> 
> I haven't tried building mp2 against the httpd snapshot using VC6 yet,
> so that's probably worth a try at least. I'll give that a go soon.

I've tried that and it doesn't work either: VC6 builds of perl-5.8.8
(unpatched) and httpd (snapshot) work OK, but mod_perl-2.0.3 has the
same error over ap_requires() as I got with the VC8 build so it's
definitely nothing to do with manifests (or anything else VC8-specific).

I'm not sure I understood what you said about ap_requires() being
defined in terms of mpxs_ap_requires() in Access.xs. Isn't that just the
perl-level ap_requires() (i.e. Apache2::Access::ap_requires())?

The trouble is that Apache2::Access::ap_requires() calls
mpxs_ap_requires(), which then calls httpd's C-level ap_requires() if
you look at the source in Apache2__Access.h, and it is that C-level
ap_requires() function that is no longer in the httpd source code.

Am I using the wrong snapshot? My snapshot httpd identifies itself as
2.3.0-dev, rather than 2.2.5-dev like I might have expected. I
downloaded it from

http://svn.apache.org/snapshots/httpd/

I would have used the 2.2.5 RC at

http://httpd.apache.org/dev/dist/

but I get a 403/Forbidden when I try to download it :-(

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@perl.apache.org
For additional commands, e-mail: dev-help@perl.apache.org


Mime
View raw message