perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steve Hay <steve....@uk.radan.com>
Subject Re: [PATCH] Re: [ANNOUNCE] mod_perl 1.30
Date Tue, 10 Jul 2007 11:34:50 GMT
Randy Kobes wrote:
> On Fri, 30 Mar 2007, Steve Hay wrote:
>> However, something else now seems to be amiss too because after 
>> applying that patch and then building mod_perl-1.30 I find that "nmake 
>> test" doesn't do anything: it spits out the following lines (only) and 
>> then hangs until I Ctrl+C it:
> 
> This seems to be a result from some white space added in
> the generated Makefile - does the attached patch work?
> Also, as I don't have Apache/1.3 on Unix, could someone
> try this out there to make sure it's OK? Thanks.
> 
> =======================================================
> Index: Makefile.PL
> ===================================================================
> --- Makefile.PL    (revision 524700)
> +++ Makefile.PL    (working copy)
> @@ -178,7 +178,7 @@
>  write_version_h("src/modules/perl");
> 
>  my(@test_pre_init) = qq(
> -  test_pre_init:
> +test_pre_init:
>  );
> 
>  # Automatic setup support
> @@ -1540,10 +1540,10 @@
> 
>      join '', @test_pre_init,
>          qq(
> -    MP_TEST_SCRIPT=$script
> +MP_TEST_SCRIPT=$script
>  ),
>      q(
> -    TEST_VERBOSE=0
> +TEST_VERBOSE=0
> 
>  kill_httpd:
>      kill `cat t/logs/httpd.pid`
> 
> ====================================================

The above patch never got applied, so mod_perl-1.x still suffers that 
Makefile breakage at the moment. Is there any reason that it wasn't applied?

-- 

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@perl.apache.org
For additional commands, e-mail: dev-help@perl.apache.org


Mime
View raw message