perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Fred Moyer <f...@taperfriendlymusic.org>
Subject Re: [patch] test server doesn't start without mod_alias
Date Thu, 14 Sep 2006 21:42:24 GMT
On Thu, 14 Sep 2006, Geoffrey Young wrote:
> Fred Moyer wrote:
>> My httpd isn't compiled with mod_alias and make test subsequently fails
>> to start the test server.
>
> if mod_alias is missing do some tests also fail?  if so, each of those needs

Well 5 tests are failing in t/response/TestDirective/perldo.pm and it 
looks like they are related to the newly commented out section in 
t/conf/extra.last.conf.in.  Great catch, I wasn't sure if it related but 
upon further investigation it was caused by the new mod_alias conditional.

#Single-line $PerlConfig
<Perl>
if (Apache::Test::have_module('mod_alias.c')) {
   $PerlConfig = "Alias /perl_sections_perlconfig_scalar @DocumentRoot@";
}
</Perl>

# testing : $PerlConfig
# expected: 1
# received:
not ok 18
# testing : $PerlConfig
# expected: 1
# received:
not ok 19
# testing : $PerlConfig
# expected: 1
# received:
not ok 20
# testing : @PerlConfig
# expected: 1
# received:
not ok 21
# testing : @PerlConfig
# expected: 1
# received:

>  plan tests => 1, need_module('mod_alias');
>
> in there...

done

Index: t/response/TestDirective/perldo.pm
===================================================================
--- t/response/TestDirective/perldo.pm  (revision 443450)
+++ t/response/TestDirective/perldo.pm  (working copy)
@@ -12,7 +12,7 @@
  sub handler {
      my $r = shift;

-    plan $r, tests => 22;
+    plan $r, tests => 22, need_module('mod_alias');

> thanks for your diligence, fred :)

no problem geoff, glad to help.  this stuff keeps me out of trouble :)


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@perl.apache.org
For additional commands, e-mail: dev-help@perl.apache.org


Mime
View raw message