perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Randy Kobes <ra...@theoryx5.uwinnipeg.ca>
Subject Re: Apache/2.2.2 on Win32
Date Wed, 24 May 2006 06:19:02 GMT
On Tue, 23 May 2006, Randy Kobes wrote:

> On Win32 (ActivePerl 817, based on perl-5.8.8), there
> are a few failures using Apache/2.2.2 with the svn
> mod_perl sources. One set of failures is the
> apr-ext tests:
[ ... ]

The problem with these tests turned out to be that
mp2 is using the config scripts for apr and apu
to be named apr-1-config and apu-1-config (as
is found in Apache/2.2), but the Win32 scripts
I had made up were using the old names of apr-config
and apu-config (this had the effect of not defining
MP_HAVE_APR_LIBS in the top-level Makefile.PL). I've 
updated these scripts on the perl.apache.org site to
use the new names, and after reinstalling these,
and making a small change in the xs/APR/APR/Makefile.PL
to allow for the "1" in libapr-1.lib, these problems
with the apr-ext tests disappear.

There's still some individual failures of some
tests on Win32 with Apache/2.2, but these are
unrelated to the above problem.

-- 
best regards,
Randy

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@perl.apache.org
For additional commands, e-mail: dev-help@perl.apache.org


Mime
View raw message