perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Philippe M. Chiasson" <go...@ectoplasm.org>
Subject Re: add_config test
Date Mon, 13 Mar 2006 23:22:10 GMT
Randy Kobes wrote:
> The t/TestAPI/add_config test fails for me on Win32
> because the current way of getting the directory in
> on line 58 of add_config.pm produces an invalid directory
> name on Windows due the the presence of the drive letter.
> This diff:
> 
> =====================================================
> Index: add_config.pm
> ===================================================================
> --- add_config.pm	(revision 385119)
> +++ add_config.pm	(working copy)
> @@ -3,6 +3,7 @@
>   use strict;
>   use warnings FATAL => 'all';
> 
> +require File::Spec;
>   use Apache2::Access ();
>   use Apache2::CmdParms ();
>   use Apache2::RequestUtil ();
> @@ -54,7 +55,7 @@
>       $r->pnotes(add_config2 => "$@");
> 
>       eval {
> -        my $directory = join '/', ('', $r->document_root,
> +        my $directory = 
> File::Spec::Unix->catfile($r->document_root,
>                                      'TestAPI__add_config');

Wouldn't that be

File::Spec->catfile() ?

>           $r->add_config(["<Directory $directory>",
>                         'AllowOverride All Options'.$o,
> 

--------------------------------------------------------------------------------
Philippe M. Chiasson m/gozer\@(apache|cpan|ectoplasm)\.org/ GPG KeyID : 88C3A5A5
http://gozer.ectoplasm.org/     F9BF E0C2 480E 7680 1AE5 3631 CB32 A107 88C3A5A5

Mime
View raw message