perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Frank Wiles <fr...@wiles.org>
Subject Re: issues with figuring out which mp version is running
Date Tue, 24 Jan 2006 01:10:37 GMT
On Mon, 23 Jan 2006 16:05:57 -0600
Frank Wiles <frank@wiles.org> wrote:

>   I'll also update the docs to reflect this as there are a couple 
>   of places this needs to change. 

  Here is a patch to update the docs to get rid of the use of
  $mod_perl::VERSION in the 2.0 docs.  I've basically replaced 
  any use of: 

  use constant MP2 => ($mod_perl::VERSION >= 1.99);

  or the similar constructs with:

  use constant MP2 => ( exists $ENV{MOD_PERL_API_VERSION} and 
                        $ENV{MOD_PERL_API_VERSION} >= 2 ); 

  I also removed a paragraph about how you need to make sure your
  module's $VERSION appears before using $mod_perl::VERSION in the code
  otherwise CPAN freaks out.  I removed it because it no longer made
  sense to have it there, since it wasn't talking about
  $mod_perl::VERSION any longer. 

  Let me know if you want me to change anything. 

 ---------------------------------
   Frank Wiles <frank@wiles.org>
   http://www.wiles.org
 ---------------------------------


Mime
View raw message