perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Philip M. Gollucci" <pgollu...@p6m7g8.com>
Subject Re: -Wdeclaration-after-statement is not recognized by gcc 3.3.5 on openbsd3.7
Date Wed, 14 Dec 2005 01:39:38 GMT
> The insertion of -Wdeclaration-after-statement breaks the build as the 
> following gcc version doesn't support it:
>
> cc -I/home/stas/src/mod_perl-2.0.2/src/modules/perl 
> -I/home/stas/src/mod_perl-2.0.2/xs -I/home/stas/httpd/prefork-2.0.55/include 
> -I/home/stas/httpd/prefork-2.0.55/include -I/usr/local/include 
> -I/home/stas/httpd/prefork-2.0.55/include -fno-strict-aliasing 
> -fno-delete-null-pointer-checks -pipe -I/usr/local/include 
> -I/usr/libdata/perl5/i386-openbsd/5.8.6/CORE -DMOD_PERL -Wall 
> -Wmissing-prototypes -Wstrict-prototypes -Wmissing-declarations -Werror 
> -DAP_DEBUG -DAP_HAVE_DESIGNATED_INITIALIZER -Wdeclaration-after-statement 
> -DMP_COMPAT_1X -g -DMP_DEBUG -DMP_TRACE -D_POSIX_THREADS 
> d_perl.c && mv mod_perl.o mod_perl.lo
> cc1: error: unrecognized option `-Wdeclaration-after-stat
> *** Error code 1
>
>
> gcc -v
> Reading specs from /usr/lib/gcc-lib/i386-unknown-openbsd3.7/3.3.5/specs
> Configured with:
> Thread model: single
> gcc version 3.3.5 (propolice)
>
> Not sure what to do about it, the mp2 build code assumes that any gcc above 
> 3.3.2 should have it:
>
>        if ($self->has_gcc_version('3.3.2') &&
>            $ccopts !~ /declaration-after-statement/) {
>            debug "Adding -Wdeclaration-after-statement to ccopts";
>            $ccopts .= " -Wdeclaration-after-statement";
>        }
>    }
D'oh, thats relatively new things too.  As its the only case I've heard 
of, I suggest we IF() protect it.  IS gcc4.0 on OpenBsd yet  -- might be 
kin 3.8 ?

Grumble....


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@perl.apache.org
For additional commands, e-mail: dev-help@perl.apache.org


Mime
View raw message