perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Geoffrey Young <ge...@modperlcookbook.org>
Subject Re: maintainer mode (was Re: httpd 2.3.01 and t/modules/proxy.t)
Date Thu, 29 Sep 2005 12:38:22 GMT


Joe Orton wrote:
> On Wed, Sep 28, 2005 at 11:08:58AM -0400, Geoffrey Young wrote:
> 
>>Philip M. Gollucci wrote:
>>
>>>2.0.47 bus core dumps when you attempt to run it despite compiling under
>>>maintainer mode.
>>>I believe this is your same core dump mentioned above.
>>
>>yeah, sounds like it.  mod_perl won't even build for me because httpd -l
>>dumps core
> 
> 
> Yup, this is the specific bug I mentioned.  If using an old version of 
> gcc is not practical you can apply the patches to fix it in APR:
> 
> http://svn.apache.org/viewcvs.cgi?rev=58984&view=rev
> 
> though this somewhat erodes the value of testing against "2.0.47" or 
> whatever.

somewhat, but not entirely.  the things that concern me most are macros,
constants, subroutines, etc that exist only in later versions that somehow
creep into our codebase inadvertently, making it difficult or impossible to
compile or run mod_perl against older versions of httpd.  so, in that sense
getting httpd to compile so we can "test" against it is a good thing.

so, thanks for the link :)

--Geoff

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@perl.apache.org
For additional commands, e-mail: dev-help@perl.apache.org


Mime
View raw message