perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Philip M. Gollucci" <>
Subject MP2 + Bleedperl broken
Date Mon, 15 Aug 2005 05:48:17 GMT
Hi all,

A while ago, Stas reported an issue in bleedperl with
Perl_croak(aTHX_ Nullch);

Then, rgs fixed it here:
This worked, and AFAIK, this hasn't been backed out or changed.

with bleedperl via rsync as of tonight, and mp2 svn trunk

I get this again:

-fno-strict-aliasing -Wdeclaration-after-statement -I/usr/local/include 
-DMOD_PERL -Wall -Wmissing-prototypes -Wstrict-prototypes 
-Wmissing-declarations -Werror -DAP_DEBUG 
-DAP_DEBUG -ggdb3 -O0 -DPIC -fPIC  -c modperl_error.c && mv 
modperl_error.o modperl_error.lo
modperl_error.c: In function `modperl_croak':
modperl_error.c:93: warning: null format string
*** Error code 1

Stop in 
*** Error code 1

Line 93 is still:
Perl_croak(aTHX_ Nullch);

If it helps anyone, here's the start of the original mp2 thread.

     What doesn't kill us can only make us stronger.
                 Nothing is impossible.
Philip M. Gollucci ( 301.254.5198
Consultant /
Senior Developer / Liquidity Services, Inc.

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message