perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Philippe M. Chiasson" <go...@ectoplasm.org>
Subject Re: Static MP2 builds
Date Mon, 25 Jul 2005 18:55:51 GMT
Philip M. Gollucci wrote:
> Hi,
> 
> I'm finally getting around to testing/trying static builds.
> 
> Unfortunately, I'm not getting very far:
> 
> So I'm being crazy and using perl 5.9.3 with ithreads
> and SVN checkouts of httpd, apr, apr-utill, and mod_perl.
> apr and apr-util are in httpd/srclib.
> 
> I ran httpd's ./buildconf first per instructions on the website. (also
> ran apr's buildconf -- probably should ammend to say do that too)  This
> also applies to apr-util me thinks.
> 
> So I went to instigate the error below
> [  error] Can't find apr include/ directory,
> [  error] use MP_APR_CONFIG=/path/to/apr-config
> 

You are missing: MP_USE_STATIC=1 in there...

> CFLAGS="-DAP_UNSAFE_ERROR_LOG_UNESCAPED -ggdb3 -O0"  \
>  $PREFIX/perl/bin/perl Makefile.PL \
>  MP_MAINTAINER=1 \
>  MP_DEBUG=1 \
>  MP_TRACE=1 \
>  MP_AP_PREFIX=/usr/local/dev/repos/ASF/httpd/httpd/trunk \
>  MP_AP_CONFIGURE=" \
>         --prefix=$PREFIX/httpd \
>         --with-perl=$PREFIX/perl/bin/perl \
>         --enable-v4-mapped \
>         --with-dbm=sdbm \
>         --with-ssl=/usr \
>         --enable-ssl \
>         --enable-so \
>         --with-port=8004 \
>         --with-mpm=worker \
>         --with-expat=/usr/local \
>         --enable-maintainer-mode \
>         --enable-threads \
>         --enable-debug \
>         --enable-mods-shared=all \
>         --enable-modules=all \
>         --enable-deflate=shared \
>         --enable-proxy=shared \
>         --enable-threads \
>         --disable-log-forensic  "

--------------------------------------------------------------------------------
Philippe M. Chiasson m/gozer\@(apache|cpan|ectoplasm)\.org/ GPG KeyID : 88C3A5A5
http://gozer.ectoplasm.org/     F9BF E0C2 480E 7680 1AE5 3631 CB32 A107 88C3A5A5

Mime
View raw message