perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Philip M. Gollucci" <pgollu...@p6m7g8.com>
Subject Static MP2 builds
Date Sun, 24 Jul 2005 02:03:28 GMT
Hi,

I'm finally getting around to testing/trying static builds.

Unfortunately, I'm not getting very far:

So I'm being crazy and using perl 5.9.3 with ithreads
and SVN checkouts of httpd, apr, apr-utill, and mod_perl.
apr and apr-util are in httpd/srclib.

I ran httpd's ./buildconf first per instructions on the website. (also 
ran apr's buildconf -- probably should ammend to say do that too)  This 
also applies to apr-util me thinks.

So I went to instigate the error below
[  error] Can't find apr include/ directory,
[  error] use MP_APR_CONFIG=/path/to/apr-config

So I went and looked at lib/Apache2/Build.pm

in sub get_apr_config()

	[...]
   for (@tries) {
         next unless $_ && -e catfile $_, "apr.h";
         $self->{apr_includedir} = $_;
         last;
     }

     unless ($self->{apr_includedir}) {
         error "Can't find apr include/ directory,",
             "use MP_APR_CONFIG=/path/to/apr-config";
         exit 1;
     }

So its looking for apr.h --- this doesn't exist yet as
apr's configure hasn't been run.

	 ? AM I GOING Crazy ?

Maybe a patch (I'll craft it) so that if $self->httpd_is_source_tree
is set, then it looks for apr.h.in

--------------------

CFLAGS="-DAP_UNSAFE_ERROR_LOG_UNESCAPED -ggdb3 -O0"  \
  $PREFIX/perl/bin/perl Makefile.PL \
  MP_MAINTAINER=1 \
  MP_DEBUG=1 \
  MP_TRACE=1 \
  MP_AP_PREFIX=/usr/local/dev/repos/ASF/httpd/httpd/trunk \
  MP_AP_CONFIGURE=" \
         --prefix=$PREFIX/httpd \
         --with-perl=$PREFIX/perl/bin/perl \
         --enable-v4-mapped \
         --with-dbm=sdbm \
         --with-ssl=/usr \
         --enable-ssl \
         --enable-so \
         --with-port=8004 \
         --with-mpm=worker \
         --with-expat=/usr/local \
         --enable-maintainer-mode \
         --enable-threads \
         --enable-debug \
         --enable-mods-shared=all \
         --enable-modules=all \
         --enable-deflate=shared \
         --enable-proxy=shared \
         --enable-threads \
         --disable-log-forensic  "

no conflicting prior mod_perl version found - good.
Configuring Apache/2.3.01 mod_perl2/2.0.2-dev Perl/vv5.9.3
[  error] Can't find apr include/ directory,
[  error] use MP_APR_CONFIG=/path/to/apr-config
cd /usr/local/dev/repos/ASF/perl/modperl/trunk ; make all install
cd "src/modules/perl" && make
make: don't know how to make 
/usr/local/apps/5.9.3-ithreads_2.1.7_work//perl/lib/CORE/libperl.so. Stop
*** Error code 2

Stop in /usr/local/dev/repos/ASF/perl/modperl/trunk.




-- 
END
------------------------------------------------------------
     What doesn't kill us can only make us stronger.
                 Nothing is impossible.
				
Philip M. Gollucci (pgollucci@p6m7g8.com) 301.254.5198
Consultant / http://p6m7g8.net/Resume/
Senior Developer / Liquidity Services, Inc.
   http://www.liquidityservicesinc.com
        http://www.liquidation.com
        http://www.uksurplus.com
        http://www.govliquidation.com
        http://www.gowholesale.com


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@perl.apache.org
For additional commands, e-mail: dev-help@perl.apache.org


Mime
View raw message