perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Geoffrey Young <ge...@modperlcookbook.org>
Subject Re: 1.99 vs 2.0
Date Tue, 05 Jul 2005 16:46:16 GMT

>> where exactly do you mean?
>>
>> --Geoff
>>  
>>
> For Instance:
> http://perl.apache.org/docs/2.0/user/porting/compat.html#mod_perl_1_0_and_2_0_Constants_Coexistence

ugh, that page is a mess :)

  if ($ENV{MOD_PERL_API_VERSION} == 2) {
    use Apache2::Const qw(OK);
  }
  else {
    use Apache::Constants qw(OK);
  }

should be more than sufficient for that entire page I would think.  if
someone wants to move to the -compile option to save overhead I'm sure they
can figure out how it works :)

> The 1.99 would include things before the API change and wouldn't work. 
> Also, don't we want to "suggest"
> not using anything before 2.0.0 anyway?

well, I don't think the issue there is as clear cut as I'd like it to be.
sure, we ought to be promoting 2.0, but 1.99 is _everywhere_, in particular
versions of redhat and debian that lots of our userbase uses.  but if we
stick to MOD_PERL_API_VERSION then 1.99 v 2.0 is a non-issue - if you have
mp2 but that test fails you're on way too old a version :)

--Geoff

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@perl.apache.org
For additional commands, e-mail: dev-help@perl.apache.org


Mime
View raw message