perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nick *** <doink...@abv.bg>
Subject Re: Some small fixes...
Date Wed, 11 May 2005 08:20:30 GMT
 >Thanks, committed.
 >
 >> I didn't use File::Copy, because it's not use(d) at the beginning of Build.pm, so
I thought it isn't loaded.
 >
 >It should be loaded. I've added the loading.
 >

Thanks Stas. Meanwhile I've cooked another patch, but first...
This code in ModPerl::BuildOptions bugs me:

if ($build->{MP_AP_PREFIX} and $build->{MP_APR_CONFIG}) {
        error "You need to pass either MP_AP_PREFIX or MP_APR_CONFIG, " .
"but not both";
         die "\n";
     }

Why MP_AP_PREFIX and MP_APR_CONFIG cannot be used together? I guess
this is valid only when MP_AP_PREFIX is pointing to an installed httpd,
because when MP_AP_PREFIX is pointing to a source tree, I can
get around this check by adding MP_AP_CONFIGURE="--with-apr=...".
It's logical to me that this check should work only when MP_AP_PREFIX is not pointing to a
source tree, because, I think, it shouldn't be possible to build mod_perl with different apr
than the one httpd was build with. But then again, if the above is true, there should be the
same check for MP_APR_CONFIG and MP_APXS, because as I see in Apache2::Build, MP_APR_CONFIG
will take precedence over the value supplied by apxs.
Is my guess a good one?


-----------------------------------------------------------------
http://host.GBG.bg - лидер в Уеб Хостинг решения и регистрация
на Домейн имена

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@perl.apache.org
For additional commands, e-mail: dev-help@perl.apache.org


Mime
View raw message