perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Geoffrey Young <ge...@modperlcookbook.org>
Subject Re: [mp2 patch] detection problems
Date Tue, 26 Apr 2005 17:41:41 GMT


Stas Bekman wrote:
> Stas Bekman wrote:
> 
>> I'm not quite sure I understand why I can't install mp2 if mp1 is
>> installed? I thought the whole deal was about making it possible to
>> have both, no?
> 
> 
> sorry, that was a false alarm.
> 
> I've nuked Apache2/ but Apache2.pm was still there. So the detection
> code got all confused. May be it needs to be improved to just die if it
> finds Apache2.pm, which is no longer in mp2?

yeah, it was in my mind to do something like that originally, but every time
I started to code it in I either got distracted or my mind started racing
with alternative scenarios that wouldn't be caught.

anyway, I think what we have is decent but clearly could be better.  if you
have the inclination anything you want to do with it is fine.  my thought is
that we should refuse to install if either Apache2.pm is found or
mod_perl.pm > 1.99 is found.

--Geoff

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@perl.apache.org
For additional commands, e-mail: dev-help@perl.apache.org


Mime
View raw message