perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Geoffrey Young <ge...@modperlcookbook.org>
Subject Re: building mp2 with a prior install
Date Mon, 18 Apr 2005 13:16:50 GMT

> - if this problem arises just because an old Apache2.pm is
> still there, and nothing else, perhaps Makefile.PL should
> abort if it finds Apache2.pm? The above error message
> doesn't really suggest what's causing the problem.

that was my original intent, but I guess the Makefile.PL code migrated in
such a way that it is allowed to still be there.

although it makes the logic more complex, we probably ought to

  - require Apache2 and refuse to install if found
  - require mod_perl and refuse to install if > 1.99

that doesn't guarantee that all old mod_perl modules are found, but between
the two we should probably be reasonably sure that they won't conflict with
the current installation path.

sorry we didn't really hack this fully out before RC5.

--Geoff

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@perl.apache.org
For additional commands, e-mail: dev-help@perl.apache.org


Mime
View raw message