perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Markus Wichitill <ma...@gmx.de>
Subject Re: Version numbers in CPAN shell
Date Thu, 07 Apr 2005 10:06:34 GMT
Stas Bekman wrote:
> How about this patch, that better fits our style guidelines:
> 
> Index: lib/ModPerl/BuildMM.pm
> ===================================================================
> --- lib/ModPerl/BuildMM.pm      (revision 160192)
> +++ lib/ModPerl/BuildMM.pm      (working copy)
> @@ -189,8 +189,8 @@
>      # create a dependency on pm_to_blib subdirs linkext targets to
>      # allow 'make -j'
>      require ExtUtils::MakeMaker;
> -    my $pm_to_blib = ($ExtUtils::MakeMaker::VERSION >= 6.22 &&
> -                      $ExtUtils::MakeMaker::VERSION <= 6.25 )
> +    my $mm_ver = $ExtUtils::MakeMaker::VERSION;
> +    my $pm_to_blib = ($mm_ver >= 6.22 && $mm_ver <= 6.25 )
>          ? "pm_to_blib.ts"
>          : "pm_to_blib";
>      my @target = ("glue_pods: $pm_to_blib subdirs linkext");

Works fine, too.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@perl.apache.org
For additional commands, e-mail: dev-help@perl.apache.org


Mime
View raw message