perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stas Bekman <s...@stason.org>
Subject Re: svn up doesn't work after svn tree merging
Date Tue, 05 Apr 2005 17:39:21 GMT
Brian W. Fitzpatrick wrote:
> On Tue, 2005-04-05 at 13:09 -0400, Stas Bekman wrote:
> 
>>Brian W. Fitzpatrick wrote:
>>
>>>Have you tried checking out a new working copy?  Is this after
>>>successfully committing the merge, or before?
>>
>>Checking out a new copy is fine. In fact a checkout in another tree which 
>>had no changes worked fine as well.
>>
>>The events were as follows;
>>
>>1) check out trunk
>>
>>2) do changes
>>
>>3) meanwhile another tree was merged with trunk (lots of files moved)
>>
>>4) svn up - no workie
> 
> 
> Hmm.  It may be a bug in update when replacing a merged file... can you
> manage to reproduce it by checking out a working copy at a revision
> before the big merge, and then trying to update.  If you can do this,
> please shoot me the recipe.

As I said an unmodified tree checked previously works fine. It's the 
changed tree that is problematic. So I need to know which file to try to 
change. However there are many files. The error:

% svn up
 > svn: Delta source ended unexpectedly

doesn't give me a single clue to which file it has a problem with. And I 
can't find a flag that makes the output more verbose than that.

-- 
__________________________________________________________________
Stas Bekman            JAm_pH ------> Just Another mod_perl Hacker
http://stason.org/     mod_perl Guide ---> http://perl.apache.org
mailto:stas@stason.org http://use.perl.org http://apacheweek.com
http://modperlbook.org http://apache.org   http://ticketmaster.com

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@perl.apache.org
For additional commands, e-mail: dev-help@perl.apache.org


Mime
View raw message