perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stas Bekman <>
Subject Re: svn up doesn't work after svn tree merging
Date Tue, 05 Apr 2005 17:09:05 GMT
Brian W. Fitzpatrick wrote:
> Have you tried checking out a new working copy?  Is this after
> successfully committing the merge, or before?

Checking out a new copy is fine. In fact a checkout in another tree which 
had no changes worked fine as well.

The events were as follows;

1) check out trunk

2) do changes

3) meanwhile another tree was merged with trunk (lots of files moved)

4) svn up - no workie

> -Fitz
> On Tue, 2005-04-05 at 12:46 -0400, Stas Bekman wrote:
>>modperl2 has recently went through an svn tree merge, which moved many 
>>files around. Result: I no longer can update my tree with multiple changes 
>>which happened before the merge:
>>% svn up
>>svn: Checksum mismatch for 
>>recorded: '98aeb94004bfcca1eaa1ca5a11418926', actual: 
>>nuked the t/filter/TestFilter tree completely (had no modification there), 
>>passed over this problem.
>>% svn up
>>svn: Delta source ended unexpectedly
>>I have no idea how to proceed.
>>Are those bugs in subversion? Or did the merging go wrong?
>>svn 1.1.3-11mdk here.

Stas Bekman            JAm_pH ------> Just Another mod_perl Hacker     mod_perl Guide --->

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message