perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joe Schaefer <joe+gm...@sunstarsys.com>
Subject Re: CGI.pm dependency in Apache2::Status
Date Fri, 11 Mar 2005 22:28:40 GMT
"Christopher H. Laco" <claco@chrislaco.com> writes:

> Geoffrey Young wrote:
>
>>>While I'm sure my opinion is extremely low on the totem, I'd much prefer:
>>>
>>>    $ENV{MOD_PERL} and $ENV{MOD_PERL_VERSION}
>> yeah, I was going to suggest something along these lines.  perhaps
>> MOD_PERL_API_VERSION which we can use to affect abi compat or something.  I
>> just didn't know if the overhead of another mandatory insertion into %ENV
>> was worth it, but we may be leaving ourselves with no recourse here.
>
> That's what led me to the other option of actually setting $ENV{MOD_PERL} to
> the verion instead of just true; the two birds with one stone thing.

But we can't wind the clock back for mp1, so whatever its
been producing in $ENV{MOD_PERL} isn't something we 
should try to change now.  +1 for either documenting the format
of $ENV{MOD_PERL} so folks can parse it, or (preferably)
creating a new env variable that contains either the 
version number or the API generation.

-- 
Joe Schaefer


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@perl.apache.org
For additional commands, e-mail: dev-help@perl.apache.org


Mime
View raw message