perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stas Bekman <s...@stason.org>
Subject Re: New ModPerl-Registry/t/ithreads.t test fails on Win32
Date Tue, 08 Feb 2005 13:26:02 GMT
Steve Hay wrote:
> Stas Bekman wrote:
> 
> 
>>Steve Hay wrote:
>> 
>>
>>
>>># expected: thread 1
>>># thread 2
>>># thread 3
>>># thread 4
>>># parent
>>># received: thread 1
>>># thread 2
>>># thread 3
>>># parent
>>>not ok 1
>>>FAILED test 1
>>>       Failed 1/1 tests, 0.00% okay
>>>Failed Test  Stat Wstat Total Fail  Failed  List of Failed
>>>-------------------------------------------------------------------------------
>>>t\ithreads.t                1    1 100.00%  1
>>>Failed 1/1 test scripts, 0.00% okay. 1/1 subtests failed, 0.00% okay.
>>>[warning] server localhost:8529 shutdown
>>>[  error] error running tests (please examine t\logs\error_log)
>>>
>>>I don't understand what happened to thread 4 :(
>>>   
>>>
>>
>>most likely the thing that I've suggested in reply to Joe. By the time it 
>>sent its print the parent has returned. Try to add sleep 2 before print 
>>'parent'. Does it fix the problem (notice that I've committed a change).
>>
> 
> Yes - adding the sleep 2 before print 'parent' does indeed fix it.  
> (Your changed version still didn't work without that sleep, though.)

Yes, I know. And if you uncomment out the 3 join calls? It should work I 
believe (with the scalar leaked reports though).

-- 
__________________________________________________________________
Stas Bekman            JAm_pH ------> Just Another mod_perl Hacker
http://stason.org/     mod_perl Guide ---> http://perl.apache.org
mailto:stas@stason.org http://use.perl.org http://apacheweek.com
http://modperlbook.org http://apache.org   http://ticketmaster.com

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@perl.apache.org
For additional commands, e-mail: dev-help@perl.apache.org


Mime
View raw message