perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stas Bekman <s...@stason.org>
Subject Re: [WISHLIST] Be able to troubleshoot config file with perl -cx as before
Date Wed, 02 Feb 2005 03:28:40 GMT
Dominique Quatravaux wrote:
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> Dear Stas and fellow mod_perl maintainers,
> 
> I would like to be able to do the "perl -cx"-on-the-Apache-config-file
> trick described in the Eagle book ("Debugging <perl> sections" in
> chapter 8, page 420 in my edition but 428 in some others according to
> Google), but I run across the following problem:
> 
> $ perl -e 'use strict; use Apache2; use Apache::compat;'
> Bareword "Apache::ServerUtil::server_root" not allowed while "strict
> subs" in use at /usr/local/lib/perl/5.6.1/Apache2/Apache/compat.pm
> line 329.
> BEGIN not safe after errors--compilation aborted at
> /usr/local/lib/perl/5.6.1/Apache2/Apache/compat.pm line 412.
> Compilation failed in require at -e line 1.
> BEGIN failed--compilation aborted at -e line 1.
> 
> And consequently perl -cx on my Apache configuration file does not
> reliably syntax-check my
> <perl> section.
> 
> I am running mod_perl 1.999.20, I reckon everything else is irrelevant
> to this particular problem.

This is not going to work, since it requires a running mod_perl. I'm 
pretty sure the perl -cx worked in mp1 only in certain cases, where no 
mod_perl symbols were used. Try the modperl1 config where you use some 
Apache module and you will get the same problem.

-- 
__________________________________________________________________
Stas Bekman            JAm_pH ------> Just Another mod_perl Hacker
http://stason.org/     mod_perl Guide ---> http://perl.apache.org
mailto:stas@stason.org http://use.perl.org http://apacheweek.com
http://modperlbook.org http://apache.org   http://ticketmaster.com

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@perl.apache.org
For additional commands, e-mail: dev-help@perl.apache.org


Mime
View raw message