perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joe Orton <jor...@redhat.com>
Subject Re: New ModPerl-Registry/t/ithreads.t test fails on Win32
Date Mon, 07 Feb 2005 21:28:23 GMT
On Mon, Feb 07, 2005 at 05:39:03PM +0000, Steve Hay wrote:
> What is it with tests called "ithreads.t"?
> 
> Here's what I get @rev151728:

This started failing in my Linux builds too as of 2005-02-05 on:

Perl 5.8.5 on ppc, Perl 5.8.5 on i386, Perl 5.8.3 on i386

but is passing on:

Perl 5.8.0 on i386, Perl 5.8.0 on x86_64

(same results for the last three days)

/tmp/regressj18059/2.0-root/bin/httpd  -d /tmp/regressj18059/mp-2.0/ModPerl-Registry/t -f
/tmp/regressj18059/mp-2.0/ModPerl-Registry/t/conf/httpd.conf -D APACHE2 -D PERL_USEITHREADS
using Apache/2.0.54-dev (prefork MPM)

waiting 90 seconds for server to start: ..
waiting 90 seconds for server to start: ok (waited 1 secs)
server localhost.localdomain:8529 started
t/ithreads....1..1
# Running under perl version 5.008005 for linux
# Current time local: Mon Feb  7 21:26:16 2005
# Current time GMT:   Mon Feb  7 21:26:16 2005
# Using Test.pm version 1.25
# Using Apache/Test.pm version 1.21
# expected: thread 1
# thread 2
# thread 3
# thread 4
# parent
# received: thread 1
# thread 2
# thread 3
# parentthread 4
not ok 1
FAILED test 1
	Failed 1/1 tests, 0.00% okay
Failed Test  Stat Wstat Total Fail  Failed  List of Failed
-------------------------------------------------------------------------------
t/ithreads.t                1    1 100.00%  1
Failed 1/1 test scripts, 0.00% okay. 1/1 subtests failed, 0.00% okay.

Mime
View raw message