perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stas Bekman <s...@stason.org>
Subject Re: [mp2 patch] lib/ModPerl/DummyVersions.pm
Date Thu, 13 Jan 2005 22:16:05 GMT
Philippe M. Chiasson wrote:
> Stas Bekman wrote:
> 
>> Philippe M. Chiasson wrote:
>>
>>> Stas Bekman wrote:
>>>
>>>> Randy Kobes wrote:
>>>>
>>>>> On Tue, 4 Jan 2005, Stas Bekman wrote:
>>>>>
>>>>> [...]
>>>>>
>>>>>> the issues:
>>>>>>
>>>>>> 1) I'm not sure APR modules should get their versions as
>>>>>> 2.0.0. Should it be 0.9 instead? since Apache 2.0 uses
>>>>>> libapr 0.9.x.
>>>>>
>>>>>
>>>>>
>>>>> +1: that seems to make sense.
>>>
>>>
>>>
>>> -0: Like I said earlier, I am not sure how we can ensure we bump
>>> these 0.9 versions on each new mp2 release.
>>
>>
>>
>> At the moment we don't know what's happening with APR interface, so 
>> may be leaving it at 0.9 until we know is fine.
> 
> 
> Having APR versions set to 0.009000 is causing problems with the CPAN 
> indexer
> since the previous versions were 0.01 :
> 
>      module: APR::PerlIO
>     version: 0.009000
>     in file: mod_perl-2.0.0-RC3/xs/APR/PerlIO/PerlIO.pm
>      status: Not indexed because
>              mod_perl-2.0.0-RC2-XMas/xs/APR/PerlIO/PerlIO.pm in
>              G/GO/GOZER/mod_perl-2.0.0-RC2-XMas.tar.gz has a higher
>              version number (0.01)
> 
> So unless someone can find a better solution, the straightforward fix 
> would seem
> to automatically assing $mod_perl::VERSION to APR::* modules as well.
> 
> Index: lib/ModPerl/WrapXS.pm
> ===================================================================
> --- lib/ModPerl/WrapXS.pm    (revision 125085)
> +++ lib/ModPerl/WrapXS.pm    (working copy)
> @@ -367,8 +367,7 @@
>  sub module_version {
>      local $_ = shift;
>      require mod_perl;
> -    # XXX: for now APR gets its libapr-0.9 version
> -    return /^APR/ ? "0.009000" : "$mod_perl::VERSION";
> +    return "$mod_perl::VERSION";
>  }
> 
>  sub write_makefilepl {

Nuh, this is not right. APR versioning has nothing to do with mod_perl. 
Especially if it gets split from mod_perl as a separate package.

just ask Andreas to nuke the previous index for all APR:: modules and 
force RC3 reindex.

You will all soon receive an email asking to transfer your Apache:: module 
sownership to APML. Once this is done, a simple reindex will fix problems 
like that.

-- 
__________________________________________________________________
Stas Bekman            JAm_pH ------> Just Another mod_perl Hacker
http://stason.org/     mod_perl Guide ---> http://perl.apache.org
mailto:stas@stason.org http://use.perl.org http://apacheweek.com
http://modperlbook.org http://apache.org   http://ticketmaster.com

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@perl.apache.org
For additional commands, e-mail: dev-help@perl.apache.org


Mime
View raw message