perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Peacock <jpeac...@rowman.com>
Subject Re: [PATCH] Re: version syntax for mp2 [summary]
Date Tue, 04 Jan 2005 18:54:24 GMT
Stas Bekman wrote:

> Stas Bekman wrote:
> 
>> -    our $VERSION = "1.9920";
>> +    our $VERSION = "1.099020";
> 
> 
> It doesn't seem that we can do that until we get to 2.0, since: 1.19 
> (the current mp1 version) > 1.099020 (the current mp2 version), so any 
> code doing this checking will break. (A-T breaks already and the fix 
> would be very ugly).
> 

When going from a two significant decimal version to a three decimal 
version, you normally multiply by 10, so this would work:

	our $VERSION = "1.990020";

but since you already used 1.99_19 (i.e. 1.9919).  Perhaps you should do 
this:

	our $VERSION = "1.999999"; # or really 1.999_020 would work

and keep adding another nine for each release candidate (just get 
asymptotically closer to 2.000_000... ;)

John

-- 
John Peacock
Director of Information Research and Technology
Rowman & Littlefield Publishing Group
4501 Forbes Boulevard
Suite H
Lanham, MD  20706
301-459-3366 x.5010
fax 301-429-5748

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@perl.apache.org
For additional commands, e-mail: dev-help@perl.apache.org


Mime
View raw message