perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Geoffrey Young <ge...@modperlcookbook.org>
Subject Re: [mp2] taking a step back?
Date Tue, 04 Jan 2005 14:11:04 GMT

> And that's why Apache2_2 won't be necessary.  If Apache2 becomes
> Apache3 because they rewrite everything from scratch again, then we
> release mp3 with Apache3:: prefixes!

unfortunately, I don't think that is entirely true.  one of my Apache 2.x
modules, Apache::IncludeHook, is an XS wrapper around some mod_include
things.  mod_include was entirely rewritten between 2.0 and 2.2 such that
the XS is completely incompatible between versions.  so, to support this
particular module in 2.0 and 2.2 I would need two separate modules (or some
really complex acrobatics, but if that were acceptable we wouldn't be having
this discussion, really).

the general thought within httpd (or at least my read of it) is that they
are comfortable with semi-major API changes for minor even numbered
versions, so I suspect there are likely to be other cases like this as time
moves on.

--Geoff

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@perl.apache.org
For additional commands, e-mail: dev-help@perl.apache.org


Mime
View raw message