perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Perrin Harkins <per...@elem.com>
Subject Re: BSD::Resource needed on BSD systems
Date Wed, 05 Jan 2005 20:51:16 GMT
On Wed, 2005-01-05 at 11:07 -0500, Stas Bekman wrote:
> that's misleading. The platform is supported. I see nothing wrong with 
> having different error messages.

I was just thinking of making it easier to test, but you're right, it's
not as clear a message.

> How about just:
> 
>    croak "Unsupported platform: $^O";

Because it's a croak, I think it needs to say "Apache::SizeLimit" in
there.

I'll make the changes to use croak and just leave it at that.  I'll also
look at moving this from the startup into an official test, so that you
would get a "skipped" on unsupported platforms.  It would still just
test loading the module, but it would be less confusing I think.

- Perrin


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@perl.apache.org
For additional commands, e-mail: dev-help@perl.apache.org


Mime
View raw message