perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joe Schaefer <joe+gm...@sunstarsys.com>
Subject Re: [mp2] PAUSE indexer issues
Date Sun, 26 Dec 2004 20:23:48 GMT
Stas Bekman <stas@stason.org> writes:

> Joe Schaefer wrote:

[...]

>> I'm asking if changing the Apache::Resource provider from mp1
>> to mp2 is really what _we_ want to do, now that we know CPAN
>> will not support multi-versioning prior to mp2's release.
>
> why not? Why mp1 should be favored above mp2? 

It's not about favoritism, it's about stability.  The 
version-qualifier in META.yml's "requires"

     <URL: http://module-build.sourceforge.net/META-spec.html>

     * requires
       Example:
           Data::Dumper: 0
           File::Find: 1.03
 

       A YAML mapping indicating the Perl modules this distribution
       requires for proper operation. The keys are the module names, and
       the values are version specifications as described in the
       documentation for Module::Build's "requires" parameter.  


       Note: the exact nature of the fancy specifications like ">= 1.2,
       != 1.5, < 2.0" is subject to change. Advance notice will be given
       here. The simple specifications like "1.2" will not change in format.  


is a total fscking joke without the corresponding CPAN indexing.
But since p5p is not going to do that, is there some other way for a 
third-party module to specify "I require mp1's Apache::Resource"?
Probably not, if mp2 is occupying the same module/tarball namespaces
on CPAN.  I'm not completely convinced that this is a good idea,
so I'd like to see it discussed (again), now that we are reasonably
certain about CPAN's functionality.

-- 
Joe Schaefer


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@perl.apache.org
For additional commands, e-mail: dev-help@perl.apache.org


Mime
View raw message