perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Philippe M. Chiasson" <go...@ectoplasm.org>
Subject Re: [mp2] PAUSE indexer issues
Date Fri, 24 Dec 2004 06:08:46 GMT
Stas Bekman wrote:

> Philippe M. Chiasson wrote:
>
>>> But I'm not sure what to do about these:
>>>
>>>       module: Apache::Connection
>>>      version: undef
>>>      in file: mod_perl-2.0.0-RC2-XMas/lib/Apache/compat.pm
>>>       status: Not indexed because 
>>> mod_perl-1.29/Connection/Connection.pm
>>>               in G/GO/GOZER/mod_perl-1.29.tar.gz has a higher version
>>>               number (1.00)
>>>
>>> We do have a real Apache::Connection in mp2 but it's autogenerated. 
>>> In fact none of the autogenerated packages is indexed. So this could 
>>> be a problem. Ideas?
>>
>> Is there a way to tell about generated packages thru META.yml? 
>> provides: or
>> a keyword as such ?
>
> Even if we could, the file doesn't physically exist, unless we 
> autogenerated a dummy file which just declares packages and their 
> versions.

No, what I am saying is something similar to Bundles or the Provides: 
keyword of RPMS.
A way to tell the CPAN indexer that when it's searching for 
Apache::Connection, it should trust that
installing mod_perl 2.0 will result in that module being installed.

auto-generated: META.yml keyword maybe ?

-- 
--------------------------------------------------------------------------------
Philippe M. Chiasson m/gozer\@(apache|cpan|ectoplasm)\.org/ GPG KeyID : 88C3A5A5 
http://gozer.ectoplasm.org/     F9BF E0C2 480E 7680 1AE5 3631 CB32 A107 88C3A5A5


Mime
View raw message