perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stas Bekman <s...@stason.org>
Subject Re: a new directive: PerlStartupFile?
Date Fri, 10 Dec 2004 18:09:19 GMT
Larry Leszczynski wrote:
> Hi Stas -
> 
> 
>>As a followup to the discussed issue, we need to redefine the concept of:
>>
>>   "put those things in startup.pl"
>>
>>we now need to say:
>>
>>    "put those things in post_config phase handler"
> 
> [...]
> 
>>So there is a possibility to introduce a new directive: PerlStartupFile
>>(feel free to suggest a better name) which will be:
>>
>>PerlStartupFile "somefile.pl"
> 
> [...]
> 
>>after discussing this with gozer on irc we aren't sure this is a good
>>idea, as for most people using the old startup.pl concept will still work.
> 
> 
> Leaving things as-is sounds like it might be asking for trouble, e.g.
> people not aware of the implications between config and post-config, or
> people still using "PerlRequire startup.pl" from their mp1 setup and it
> works ok by coincidence, and suddenly stops working (or fails in
> mysterious ways) when they add something that unknowingly breaks the rules
> about config vs. post-config phases.
> 
> Maybe it would also help to introduce an alias for PerlRequire called
> something like PerlConfigFile, to make it more obvious it should only be
> used to modify config, and recommend that instead of using "PerlRequire
> startup.pl" people should do:
> 
>    PerlConfigFile  "some-file.pl"
>    PerlStartupFile "some-other-file.pl"
> 
> Or maybe since there is already PerlPostConfigHandler, parallel that and
> use the name PerlPostConfigFile instead of PerlStartupFile?:
> 
>    PerlConfigFile     "some-file.pl"
>    PerlPostConfigFile "some-other-file.pl"
> 
> (Don't know about that, maybe PerlStartupFile seems more intuitive about
> what you'd use it for...)

Thanks for the comments, Larry. But we need to put this issue on hold a 
bit, since apparently loading from config phase (startup.pl) and 
post_config phase is not exactly the same. So once we figure out why there 
is a difference I'll be able to give you a more intelligent reply.

-- 
__________________________________________________________________
Stas Bekman            JAm_pH ------> Just Another mod_perl Hacker
http://stason.org/     mod_perl Guide ---> http://perl.apache.org
mailto:stas@stason.org http://use.perl.org http://apacheweek.com
http://modperlbook.org http://apache.org   http://ticketmaster.com

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@perl.apache.org
For additional commands, e-mail: dev-help@perl.apache.org


Mime
View raw message