perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christopher H. Laco" <cl...@chrislaco.com>
Subject Re: [mp2] [PATCH] both_str_req_proxy.t - proxy/t failure progress
Date Wed, 08 Dec 2004 02:08:36 GMT
Christopher H. Laco wrote:
> Christopher H. Laco wrote:
> [snip]
> 
>> Changing my httpd.conf fixes the failing test. Now, I assumed if was 
>> just a matter of changing
>>
>> plan tests => 1, need need_module('proxy'),
>>     need_access;
>>
>>
>> to
>>
>> plan tests => 1, need need_module(['proxy', 'proxy_http']),
>>     need_access;
>>
>>
>> However, no encantation of proxy_http, mod_proxy_http.c seems to work. 
>> The all fail to recognize that mod_proxy_http.so is loaded. 
>> A::T::need_module looks fine, but maybe I'm missing something.
>>
>> Any ideas?
> 
> 
> And here's the problem.....a dump of $cfg->{modules} during need_module 
> shows this:
> 
>     ...
>     mod_deflate.c
>     mod_proxy.c
>     core.c
>     http_core.c
>     proxy_http.c    <----- Hey, that's not intuitive given the
>                 LoadModule line. :-)
>     mpm_winnt.c
>     ...
> 
> 
> Of course, it will never find it as it's assuming  mod_$module.c.
> 
> What's the best way to deal with this? Simply pass in proxy_http.c since 
> need_module leaves *.c modules as-is?
> 
> Seems kind of dirty, but it works.
> 
> -=Chris

Here's a patch to make sure we check for both the proxy and the 
proxy_http modules.


-=Chris

Mime
View raw message