perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christopher H. Laco" <cl...@chrislaco.com>
Subject [mp2] both_str_req_proxy.t - proxy/t failure progress
Date Wed, 08 Dec 2004 01:16:48 GMT
Ok, I've started looking into these. At least in my case this was the 
root error of both of these failures:

[Tue Dec 07 19:14:34 2004] [debug] mod_proxy.c(416): Trying to run 
scheme_handler

[Tue Dec 07 19:14:34 2004] [warn] proxy: No protocol handler was valid 
for the URL /TestFilter__both_str_req_proxy/foo. If you are using a DSO 
version of mod_proxy, make sure the proxy submodules are included in the 
configuration using LoadModule.


I only had the base proxy module loaded:

     LoadModule proxy_module modules/mod_proxy.so
     #LoadModule proxy_connect_module modules/mod_proxy_connect.so
     #LoadModule proxy_http_module modules/mod_proxy_http.so
     #LoadModule proxy_ftp_module modules/mod_proxy_ftp.so

when what is needed is

     LoadModule proxy_module modules/mod_proxy.so
     #LoadModule proxy_connect_module modules/mod_proxy_connect.so
     LoadModule proxy_http_module modules/mod_proxy_http.so
     #LoadModule proxy_ftp_module modules/mod_proxy_ftp.so


Changing my httpd.conf fixes the failing test. Now, I assumed if was 
just a matter of changing

plan tests => 1, need need_module('proxy'),
	need_access;


to

plan tests => 1, need need_module(['proxy', 'proxy_http']),
	need_access;


However, no encantation of proxy_http, mod_proxy_http.c seems to work. 
The all fail to recognize that mod_proxy_http.so is loaded. 
A::T::need_module looks fine, but maybe I'm missing something.

Any ideas?


-=Chris

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@perl.apache.org
For additional commands, e-mail: dev-help@perl.apache.org


Mime
View raw message