perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joe Schaefer <joe+gm...@sunstarsys.com>
Subject Re: Apache2 and Apache::Test
Date Tue, 23 Nov 2004 05:38:38 GMT
Stas Bekman <stas@stason.org> writes:

[...]

> but I'm not sure why do you see what you
> explain. mp2/Apache-Test/Makefile should be:
>
> INST_LIB = ../blib/lib
>
> and not:
>
> INST_LIB = ../blib/lib/Apache2
>
> which one do you see? 

The first one now, INST_LIB=../blib/lib, which does looks ok.
However I suspect it wasn't that way when I did the mp2 cvs-install 
a few weeks ago, because....

> did you upgrade MakeMaker by chance?

Yes, I did upgrade MakeMaker because I wanted to try Geoff's Test::More
stuff for Apache::Test.  The sequence of my actions was basically

      1) check out mp2 from cvs, prior to Geoff's Test::More patch.
      2) build, test, install mp2.  Apache::Test went under Apache2.
      3) check out httpd-test/perl-framework, after Geoff's patch.
      4) install Apache::Test and notice it did not go under Apache2.
      5) Argh!  His patch didn't work (perl was picking up the old install).
      6) Remove the old Apache::Test installation: better, but not
         quite there yet.
      7) Upgrade MakeMaker, joy!  Test::More is happily spewing
         test failures across my screen.
      8) Wait a week, then post this complaint to modperl-dev@ :-)


I think step (7) fixed mp2's INST_LIB, since everything
looks right with my mp2 install this time.

-- 
Joe Schaefer


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@perl.apache.org
For additional commands, e-mail: dev-help@perl.apache.org


Mime
View raw message