perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Philippe M. Chiasson" <go...@ectoplasm.org>
Subject Re: mp2 static build problems
Date Sat, 18 Sep 2004 22:44:12 GMT
Stas Bekman wrote:

> It's a first time I'm trying to build the static mp2. Unless I'm 
> missing something it doesn't quite work for me. I build it as:
>
> perl Makefile.PL \
> MP_INST_APACHE2=1                            \
> MP_USE_STATIC=1                              \
> MP_AP_BUILD=1                                \
> MP_GENERATE_XS=1                             \
> MP_DEBUG=1                                   \
> MP_TRACE=1                                   \
> MP_USE_GTOP=1                                \
> MP_AP_PREFIX=/home/stas/apache.org/httpd-2.0 \
> MP_AP_CONFIGURE="--with-mpm=prefork"         \
> MP_MAINTAINER=1                              \
> MP_CCOPTS='-Wall -Werror'                    \
> && make -j2 && make test
>
> against the cvs of httpd-2.0.x (not HEAD/2.1)
>
> -----
> when building against the clean source we get a non-fatal error:
> Unable to open
> /home/stas/apache.org/httpd-2.0/srclib/apr/include/apr.h: No such file
> or directory
>
> that's at get_apr_config. it probably shouldn't get into that
> function, before apache's configure is run

Yes, that can be easily fixed by making to run httpd's ./configure a bit 
earlier

> -----
>
> broken dependency: when running 'make -j':
>
> make[2]: *** No rule to make target 
> `/home/stas/apache.org/mp2-static/src/modules/perl/mod_perl.a', needed 
> by `httpd'.  Stop.
>
Good spot there stas. Gotta make sure httpd's build job is only entered 
after mod_perl.a has been
built.

> -----
>
> Finally it breaks with:
>
> LD_RUN_PATH="/usr/lib:/lib" cc  -shared -L/usr/local/lib APR.o 
> modperl_error.o modperl_bucket.o modperl_common_util.o 
> modperl_common_log.o -L/usr/local/lib -o 
> ../../../blib/arch/Apache2/auto/APR/APR.so 
> -L/home/stas/apache.org/httpd-2.0/srclib/apr -lapr-0 -lrt -lm -lcrypt 
> -lnsl -lpthread -ldl
> /usr//bin/ld: cannot find -lapr-0
> collect2: ld returned 1 exit status
>
> I'm not sure how was this supposed to work in first place. Since 
> libapr is not installed yet.
>


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@perl.apache.org
For additional commands, e-mail: dev-help@perl.apache.org


Mime
View raw message