perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Randy Kobes <ra...@theoryx5.uwinnipeg.ca>
Subject Re: time for 1.99_15?
Date Thu, 19 Aug 2004 17:36:30 GMT
On Thu, 19 Aug 2004, Steve Hay wrote:

> Randy Kobes wrote:
[ ... ]
> >Did you (or Markus?) see any problem with the modperl/pnotes
> >test? Before I left I was getting a failure on one of the
> >tests that tested if an entry exists - mine didn't. This
> >was with an ActivePerl 810 compatible Win32 perl.
> >
> No, no problems:
>
> t\modperl\pnotes....1..9
> # Running under perl version 5.008005 for MSWin32
> # Current time local: Thu Aug 19 18:08:29 2004
> # Current time GMT:   Thu Aug 19 17:08:29 2004
> # Using Test.pm version 1.25
> # Using Apache/Test.pm version 1.13
> ok 1
> # testing : $r->pnotes(key,val)
> # expected: pnotes_bar
> # received: pnotes_bar
> ok 2
> # testing : $r->pnotes(key)
> # expected: pnotes_bar
> # received: pnotes_bar
> ok 3
> # testing : ref($r->pnotes)
> # expected: HASH
> # received: HASH
> ok 4
> # testing : $r->pnotes()->{}
> # expected: pnotes_bar
> # received: pnotes_bar
> ok 5
> # testing : unset entry contents
> # expected: undef
> # received: undef
> ok 6
> ok 7
> # testing : deleted entry contents
> # expected: undef
> # received: undef
> ok 8
> ok 9
> ok
> All tests successful.
>
> This is with my own builds of 2.0.50 / 5.8.5 (perl -V below) and CVS
> this morning (9am BST).

This sounds similar to what Geoff found, so it may be
a thing that's a problem with earlier perls (pre-5.8.5?).
If that's the case cross-platform, perhaps that one
subtest (7) could be skipped for pre-5.8.5?

-- 
best regards,
randy

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@perl.apache.org
For additional commands, e-mail: dev-help@perl.apache.org


Mime
View raw message