perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Wheeler <da...@kineticode.com>
Subject DSO
Date Fri, 06 Aug 2004 20:41:03 GMT
Hi All,

Quick question about running mod_perl 1 as a DSO. If I'm understanding 
this FAQ correctly:

   
http://perl.apache.org/docs/1.0/guide/install.html#When_DSO_can_be_Used

Then I can use a DSO mod_perl 1 with Perl 5.6 and later as long as Perl 
wasn't compiled with usemymalloc='y' _and_ bincompat5005='define', 
correct?

I'm  using this code to check for a bad DSO mod_perl:

         require Config;
         if ($Config::Config{usemymalloc} eq 'y'
             && defined $Config::Config{bincompat5005}) {
             die "Your mod_perl won't work";
         }

Does that look right?

Thanks,

David
Mime
View raw message