perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Markus Wichitill <ma...@gmx.de>
Subject Re: time for 1.99_15?
Date Thu, 26 Aug 2004 04:00:58 GMT
Markus Wichitill wrote:
>> t\perl\ithreads.........................Scalars leaked: 1
>> Scalars leaked: 1
>> t\perl\ithreads.........................ok
> 
> Just now I got this instead:
> 
> t\perl\ithreads.........................Attempt to free temp 
> prematurely: SV 0x6cc4a14, Perl interpreter: 0x6c90cfc at 
> C:\Dev\debug\modperl-2.0\t\response/TestPerl/ithreads.pm line 44.
> request has failed (the response code was: 500)
> 
> Seems to have crashed Apache, as all later tests failed (but I forgot to 
> look at the process list to check if it was really gone). No crash popup 
> this time, so no JIT debugging. Didn't see anything in the error_log. 
> Can't reproduce it anymore.

I now always get this. Apache exits, but doesn't crash in a way that would 
allow me to debug it. If I attach the debugger during the "nmake test" 
execution, all I see is:

[...]
Loaded symbols for 'C:\Dev\debug\perl\lib\auto\Encode\Encode.dll'
The thread 0x3BC has exited with code 9 (0x9).
The thread 0xEC has exited with code 9 (0x9).
The thread 0x5FC has exited with code 9 (0x9).
[more threads]
The program 'C:\Dev\debug\apache\bin\apache.exe' has exited with code 9 (0x9).

At first I had suspected the new module reload voodoo, but removing that 
test didn't help.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@perl.apache.org
For additional commands, e-mail: dev-help@perl.apache.org


Mime
View raw message