perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Geoffrey Young <ge...@modperlcookbook.org>
Subject Re: APR_FIND_APR
Date Fri, 06 Aug 2004 16:09:56 GMT

> The situation with APR is no different than say BerkeleyDB.  You can't
> have the perl glue compiled against one major version and expect it to
> work in applications which are linked to another.  Once httpd-2.2 comes
> out, modperl-2 users that want to upgrade the new server must recompile 
> modperl-2, and because the libapr's are incompatible, that recompile 
> must include APR.

I guess what I was thinking about was someone who didn't care about mod_perl
or httpd at all.  that is, suppose I'm a user that simply wants perl
bindings to APR - theoretically I could download only the APR/APU source and
then build only the APR bindings, thus giving me only APR:: packages in
site_perl, no httpd (or eventually whole mod_perl?) download required.
isn't this the point of having perl's APR run outside of mod_perl?

now, sure, these APR:: classes wouldn't then work with a mod_perl built
against a different httpd/apr, but the mod_perl install would overwrite the
old ones anyway in a typical install.

or maybe I'm just confused (which I seem to be alot lately, sorry).

--Geoff

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@perl.apache.org
For additional commands, e-mail: dev-help@perl.apache.org


Mime
View raw message