perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stas Bekman <s...@stason.org>
Subject Re: [mp2] support of the perl 5.9.x dev track
Date Tue, 04 Nov 2003 09:31:52 GMT
Rafael Garcia-Suarez wrote:
> Stas Bekman wrote:
> 
>>Rafael Garcia-Suarez wrote:
>>
>>>In which way the support for 5.9.0 is different from the support
>>>for 5.8.1 ?
>>
>>5.9.0 == 5.8.2-RC1 hashing-wise. meaning that we need to support a whole bunch 
>>of special cases, which don't exist anywhere else. We certainly can do that, 
>>but it's just a lot of mess. I wish Hugo didn't rush to get 5.9.0 before 5.8.2 
>>was ready. Now 5.9.0 is somewhat between 5.8.1 and 5.8.2.
> 
> 
> Yes, you're right.
> 
> I wish Hugo released 5.9.0 just after 5.8.1, or with backing out temporarily
> all changes since 5.8.1.

Yup. He sort of released it without much prior notice. I think there was no 
notice at all ;)

>>>(I know at least one person who is considering at least semi-seriously
>>>running 5.9.0 + mp1 in production :-p)
>>
>>well, please tell me if we should provide a support for it.
> 
> 
> I was mentioning mp1. AFAIK it's fine. Oh, after all, just drop the bloody
> support for 5.9.0 if it's making things too complex.

Let's see if someone really asks nice we will add it. It just needs a bunch of 
#ifdef things which will make the already almost-unreadable code even more 
unreadable.

Another reason for not supporting 5.9.0 is that we already smoke too many 
builds ;) I smoke with:
5.005_03       5.6.2-ithread  5.8.1-ithread-nouseshrplib  blead
5.6.0          5.6.2-perlio   5.8.1-nouseperlio           blead-ithread
5.6.0-ithread  5.8.0          5.8.2                       blead-multi
5.6.1          5.8.0-ithread  5.8.2-ithread               makelinks
5.6.1-ithread  5.8.1          5.8.2-ithread-nouseshrplib
5.6.2          5.8.1-ithread  5.8.2-nouseperlio

multiplied by at least 4, for mp1, mp2/prefork, mp2/threaded and various 
special configs. amounting for almost a 100 different builds. plus smokes for 
my Apache:: Modules against each of these configs... my poor notebook is 
overheated all the time, I need to ask someone to donate me a good SMP machine ;)

>>blead yes, I didn't suggest not to support blead, I meant to suggest not to 
>>support particular blead releases but just the head ;)
>>
>>BTW, just finishing smoking 5.6.2 plays very nice with both mod_perl generations.
> 
> 
> I'm glad to hear that. I'll have to find tuits to finish 5.6.2, but
> isn't the planet already overloaded those days with new perl releases ?

As you can see on the modperl list we advise using perl 5.6.1 for mod_perl 1 
(and mod_perl 2 prefork) as a much faster alternative to 5.8.x (unless you 
need utf/threads/perlio/etc). So having 5.6.2 out, is definitely a good thing.

__________________________________________________________________
Stas Bekman            JAm_pH ------> Just Another mod_perl Hacker
http://stason.org/     mod_perl Guide ---> http://perl.apache.org
mailto:stas@stason.org http://use.perl.org http://apacheweek.com
http://modperlbook.org http://apache.org   http://ticketmaster.com


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@perl.apache.org
For additional commands, e-mail: dev-help@perl.apache.org


Mime
View raw message