perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Wheeler <da...@kineticode.com>
Subject Patch for FakeRequest
Date Mon, 16 Jun 2003 20:15:45 GMT
Hi All,

I use Apache::FakeRequest for testing, of course, but when I have a 
class that expects an argument to be isa Apache, it of course won't 
work. This patch fixes it. Could it make it in before mod_perl 1.28?

FWIW, I'd be happy to also provide a patch that implements import() so 
that users can specify what they'd like Apache::FakeRequest to inherit 
from. That'd make it useful for tests that expect an Apache::Request 
object, for example.

--- lib/Apache/FakeRequest.pm   Tue Mar 21 21:22:44 2000
+++ lib/apache/FakeRequest.pm Mon Jun 16 16:13:09 2003
@@ -1,6 +1,7 @@
  package Apache::FakeRequest;

  $Apache::FakeRequest::VERSION = "1.00";
+@Apache::FakeRequest::ISA = qw(Apache);

  sub new {
      my $class = shift;

Regards,

David

-- 
David Wheeler                                     AIM: dwTheory
david@kineticode.com                              ICQ: 15726394
http://kineticode.com/                         Yahoo!: dew7e
                                                Jabber: Theory@jabber.org
Kineticode. Setting knowledge in motion.[sm]


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@perl.apache.org
For additional commands, e-mail: dev-help@perl.apache.org


Mime
View raw message