perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stas Bekman <s...@stason.org>
Subject Re: mp2: make test fails on NetBSD 1.6.1
Date Thu, 05 Jun 2003 01:35:03 GMT
Carl Brewer wrote:
> -------------8<---------- Start Bug Report ------------8<----------
> 1. Problem Description:
> 
> Seeing this at make test time from today's CVS snapshot of mp2.
> I haven't tried this with older snapshots or releases.  The
> box is running NetBSD 1.6.1 i386. :
> 
> steel1# make test
> cd "src/modules/perl" && make -f Makefile.modperl
> /usr/bin/perl -Iblib/arch -Iblib/lib  t/TEST -clean
> *** server localhost:8529 shutdown
> APACHE_USER= APACHE_GROUP= APACHE_PORT= APACHE= APXS=  /usr/bin/perl 
> -Iblib/arch -Iblib/lib  t/TEST -verbose=0
> *** root mode: changing the fs ownership to 'nobody' (32767:39)
> /usr/local/apache2/bin/httpd  -d /data/src/modperl-2.0/t -f 
> /data/src/modperl-2.0/t/conf/httpd.conf -DAPACHE2
> using Apache/2.0.46 (prefork MPM)
> 
> waiting for server to start: ..[Thu Jun 05 09:59:34 2003] [info] 23 
> Apache:: modules loaded
> [Thu Jun 05 09:59:34 2003] [info] 5 APR:: modules loaded
> [Thu Jun 05 09:59:34 2003] [info] base server + 9 vhosts ready to run tests
> ..
> waiting for server to start: ok (waited 3 secs)
> server localhost:8529 started
> server localhost:8530 listening (TestProtocol::echo)
> server localhost:8531 listening (TestProtocol::echo_filter)
> server localhost:8532 listening (TestProtocol::eliza)
> server localhost:8533 listening (TestPreConnection::note)
> server localhost:8534 listening (TestFilter::both_str_con_add)
> server localhost:8535 listening (TestFilter::in_bbs_msg)
> server localhost:8536 listening (TestFilter::in_str_msg)
> server localhost:8537 listening (TestDirective::perlmodule)
> server localhost:8538 listening (TestDirective::perlrequire)
> server localhost:8539 listening (TestDirective::perlloadmodule3)
> server localhost:8540 listening (TestDirective::perlloadmodule4)
> server localhost:8541 listening (TestDirective::perlloadmodule5)
> server localhost:8542 listening (TestDirective::perlloadmodule6)
> Can't call method "method" on an undefined value at 
> /data/src/modperl-2.0/Apache-Test/lib/Apache/TestRequest.pm line 411.
> *** Error code 61

I thought that the reason is that you don't have LWP installed. So I was 
trying to reproduce it, but it still worked. Can you try again with this 
patch. I want to know whom to blame.

Index: t/conf/modperl_extra.pl
===================================================================
RCS file: /home/cvs/modperl-2.0/t/conf/modperl_extra.pl,v
retrieving revision 1.30
diff -u -r1.30 modperl_extra.pl
--- t/conf/modperl_extra.pl     2 Jun 2003 03:03:39 -0000       1.30
+++ t/conf/modperl_extra.pl     5 Jun 2003 01:34:25 -0000
@@ -1,3 +1,11 @@
+
+BEGIN {
+
+    use Carp;
+    $SIG{__DIE__} = \&Carp::confess;
+
+}
+
  use Socket (); #test DynaLoader vs. XSLoader workaround for 5.6.x
  use IO::File ();
  use File::Spec::Functions qw(canonpath);

__________________________________________________________________
Stas Bekman            JAm_pH ------> Just Another mod_perl Hacker
http://stason.org/     mod_perl Guide ---> http://perl.apache.org
mailto:stas@stason.org http://use.perl.org http://apacheweek.com
http://modperlbook.org http://apache.org   http://ticketmaster.com


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@perl.apache.org
For additional commands, e-mail: dev-help@perl.apache.org


Mime
View raw message