perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stas Bekman <s...@stason.org>
Subject Re: is perl re-entrant?
Date Tue, 27 May 2003 23:14:26 GMT
Ian Holsman wrote:
> hi.
> I just came across a really wierd problem with 5.6.1/apache2 prefork.
> 
> 
> I have a perl script which does/did the following
> 
> ..
> print "<!--#include virtual='x.pl' -->
> ..
> 
> now .. with straight CGI, this worked fine. but using mod-perl i get 
> some weird & wonderfull errors.. mainly when I used
> print <<EOF
> ...
> ...
> EOF
> 
> for some reason.
> 
> so.. the question.
> is perl 5.6.1 re-entrant?
> is 5.8 ?
> 
> is their a option I should be setting to enable this?

Ian, you provide too few details to be able to tell what could be the cause, 
please post the errors and the build details as explained here:
http://perl.apache.org/docs/2.0/user/help/help.html#Reporting_Problems

perl is always re-entrant when it's built without ithreads enabled. With 
threaded mp2 mpm, perl 5.8.0 or higher should be used (5.6.x is not completely 
re-entrant). I suppose that you encounter a problem with threaded mpm?




__________________________________________________________________
Stas Bekman            JAm_pH ------> Just Another mod_perl Hacker
http://stason.org/     mod_perl Guide ---> http://perl.apache.org
mailto:stas@stason.org http://use.perl.org http://apacheweek.com
http://modperlbook.org http://apache.org   http://ticketmaster.com


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@perl.apache.org
For additional commands, e-mail: dev-help@perl.apache.org


Mime
View raw message