perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Batara Kesuma <bkes...@gaijinweb.com>
Subject Re: mp2.0 - make test failed cgi.t
Date Tue, 27 May 2003 10:45:39 GMT
Hi Stas,

> You need to chdir to ModPerl-Registry dir first and then it'll work.
> 
> I've updated:
> http://perl.apache.org/docs/2.0/user/help/help.html#_C_make_test___Failures
> to include that info

You got a typo I think :) It is:
t/logs/error_log
not:
t/log/error_log


> please just post the output of that run and
> ModPerl-Registry/t/logs/error_log as explained above. No need to make
> report again and again, we have that info already more than once ;)

Ok. Here is from console:
[root@shibuya-dv1 ModPerl-Registry]# t/TEST -verbose cgi.t
*** setting ulimit to allow core files
ulimit -c unlimited; t/TEST -verbose 'cgi.t'
*** root mode: changing the fs ownership to 'nobody' (99:99)
/usr/sbin/httpd  -d
/usr/src/redhat/BUILD/mod_perl-1.99_09/ModPerl-Registry/t -f
/usr/src/redhat/BUILD/mod_perl-1.99_09/ModPerl-Registry/t/conf/httpd.conf
-DAPACHE2 -DPERL_USEITHREADS
using Apache/2.0.40 (prefork MPM)

waiting for server to start: ...
waiting for server to start: ok (waited 2 secs)
server localhost.localdomain:8529 started
cgi....1..2
# testing : test 'Content-type header setting
# expected: qr/(?-xism:^text\/html)/
# received: 'text/html; charset=iso-8859-1'
ok 1
# testing : test body
# expected: '<b>done</b>'
# received: '<!doctype html public "-//ietf//dtd html 2.0//en">
# <html><head>
# Failed test 2 in cgi.t at line 19
# <title>500 internal server error</title>
# </head><body>
# <h1>internal server error</h1>
# <p>the server encountered an internal error or
# misconfiguration and was unable to complete
# your request.</p>
# <p>please contact the server administrator,
#  root@shibuya-dv1.emercury.co.jp and inform them of the time the error
#  occurred,
# and anything you might have done that may have
# caused the error.</p>
# <p>more information about this error may be available
# in the server error log.</p>
# </body></html>
# '
not ok 2
FAILED test 2
        Failed 1/2 tests, 50.00% okay
Failed Test Stat Wstat Total Fail  Failed  List of Failed
-------------------------------------------------------------------------
------
cgi.t                      2    1  50.00%  2
*** server localhost.localdomain:8529 shutdown
!!! error running tests (please examine t/logs/error_log)



And error_log looks like:
[root@shibuya-dv1 ModPerl-Registry]# cat t/logs/error_log 
[Tue May 27 19:41:24 2003] [info] mod_unique_id: using ip addr
219.106.230.74
[Tue May 27 19:41:25 2003] [notice] Digest: generating secret for digest
authentication ...
[Tue May 27 19:41:25 2003] [notice] Digest: done
[Tue May 27 19:41:25 2003] [info] mod_unique_id: using ip addr
219.106.230.74
[Tue May 27 19:41:26 2003] [notice] Apache/2.0.40 (Red Hat Linux)
mod_perl/1.99_09 Perl/v5.8.0 DAV/2 configured -- resuming normal
operations
[Tue May 27 19:41:26 2003] [info] Server built: Sep  4 2002 17:20:34
[Tue May 27 19:41:26 2003] [debug] prefork.c(1039): AcceptMutex: sysvsem
(default: sysvsem)
[Tue May 27 19:41:27 2003] [error] 22276: ModPerl::Registry: Can't locate
Apache.pm in @INC (@INC contains:
/usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi/Apache2
/usr/src/redhat/BUILD/mod_perl-1.99_09/ModPerl-Registry/lib
/usr/src/redhat/BUILD/mod_perl-1.99_09/ModPerl-Registry/t Apache-Test/lib
/usr/src/redhat/BUILD/mod_perl-1.99_09/ModPerl-Registry/t/../lib
/usr/src/redhat/BUILD/mod_perl-1.99_09/ModPerl-Registry/t/../../Apache-Te
st/lib /usr/src/redhat/BUILD/mod_perl-1.99_09/ModPerl-Registry/t/../../lib
/usr/src/redhat/BUILD/mod_perl-1.99_09/ModPerl-Registry/t/../../blib/lib/
Apache2
/usr/src/redhat/BUILD/mod_perl-1.99_09/ModPerl-Registry/t/../../blib/arch
/Apache2
/usr/src/redhat/BUILD/mod_perl-1.99_09/ModPerl-Registry/t/../../blib/lib
/usr/src/redhat/BUILD/mod_perl-1.99_09/ModPerl-Registry/t/../../blib/arch
/usr/lib/perl5/5.8.0/i386-linux-thread-multi /usr/lib/perl5/5.8.0
/usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl/5.6.1
/usr/lib/perl5/site_perl
/usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.0 /usr/lib/perl5/vendor_perl/5.6.1
/usr/lib/perl5/vendor_perl
/usr/src/redhat/BUILD/mod_perl-1.99_09/ModPerl-Registry/t/
/usr/src/redhat/BUILD/mod_perl-1.99_09/ModPerl-Registry/t/lib/perl) at
/usr/lib/perl5/5.8.0/CGI.pm line 161.
Compilation failed in require at
/usr/src/redhat/BUILD/mod_perl-1.99_09/ModPerl-Registry/t/cgi-bin/cgi.pl
line 1.
BEGIN failed--compilation aborted at
/usr/src/redhat/BUILD/mod_perl-1.99_09/ModPerl-Registry/t/cgi-bin/cgi.pl
line 1.

[Tue May 27 19:41:27 2003] [error] server reached MaxClients setting,
consider raising the MaxClients setting
[Tue May 27 19:41:27 2003] [info] removed PID file
/usr/src/redhat/BUILD/mod_perl-1.99_09/ModPerl-Registry/t/logs/httpd.pid
(pid=22271)
[Tue May 27 19:41:27 2003] [notice] caught SIGTERM, shutting down


My Apache.pm is at:
[root@shibuya-dv1 ModPerl-Registry]# locate Apache.pm
/usr/lib/perl5/5.8.0/CGI/Apache.pm
/usr/lib/perl5/CGI/Apache.pm

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@perl.apache.org
For additional commands, e-mail: dev-help@perl.apache.org


Mime
View raw message