perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Yuriy Syrota" <ysyr...@softservecom.com>
Subject RE: AxKit porting troubles (continued)
Date Fri, 29 Nov 2002 13:01:13 GMT
Stas Bekman wrote:

> Yuriy Syrota wrote:
> > Hello, folks.
> > 
> > I performed additional investigation and now can ask the 
> question more 
> > accurately.
> > 
> > Well, let's start from the beginning. I'm porting AxKit
> > to apache2. AxKit is a mod_perl module which registers
> > itself in apache as a regular module written in C with
> > own configuration directives (there is some C code in
> > the AxKit which do it when mod_perl are loading AxKit).
> > 
> > In Apache2 this approach doesn't work because PerlModule directive 
> > does nothing at the httpd.conf parsing phase. And
> 
> if I guess correctly, your current problem is that Apache doesn't 
> recognize the extended configuration directives, because PerlModule 
> doesn't run the code that installs these directives, right 
> away. Is that 
> correct?
> 
> Would <Perl> sections / startup file help?

Startup file can't help because mod_perl executes it after apache read
configuration.
And <Perl> section seems not ready yet. After I added the following into
httpd.conf:

<Perl>
Use AxKit;
</Perl>

Httpd returned "<Perl> directive missing closing '>'"

-- Yuriy Syrota


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@perl.apache.org
For additional commands, e-mail: dev-help@perl.apache.org


Mime
View raw message