perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Matt Sergeant <m...@sergeant.org>
Subject Re: [1.3 Patch] PerlSetEnv
Date Tue, 26 Mar 2002 14:52:36 GMT
On Mon, 18 Mar 2002, Geoffrey Young wrote:

> hi all...
>
>   well, I thought I'd try to help give the 1.3 tree some forward momentum...
>
>   my thought is to run through the STATUS file and present all the available patches
for
> review and incorporation into core, and I thought I'd start with one I was pretty familiar
> with :)
>
>   PerlSetEnv seems not to work for any requests after the first request to a particular
> child - see the links in the STATUS file for the bug report, as well as the surrounding
> discussion (the bug was discovered as part of trying to fix another problem)
>
>   I traced the problem through the code and the fix seems pretty simple (in mod_perl.c).
> I added a test in t/net/perl/api.pl that fails without the patch but passes ok with it.
>
>   at any rate, all other tests pass.
>
>   I'm hoping to present one or two patches a week until at least the available patches
> board is cleared from the STATUS file - I hope that helps somewhat.

Test fails for me. I'll try and debug a bit more.

-- 
<!-- Matt -->
<:->Get a smart net</:->


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@perl.apache.org
For additional commands, e-mail: dev-help@perl.apache.org


Mime
View raw message