perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Randy Kobes <ra...@theoryx5.uwinnipeg.ca>
Subject Re: mod_perl 2.0 (current CVS) on Win32
Date Sat, 05 Jan 2002 20:32:49 GMT
On Sat, 5 Jan 2002, Sebastian Bergmann wrote:

> Randy Kobes wrote:
> > No, it shouldn't be - the install to \server\apache should also
> > copy the needed include and lib files. And there's no spaces in
> > the names, so it's not croaking on that ... If it doesn't make
> > any difference to you, what happens if you install to C:\Apache2?
> > That works for me ...
>
>   What exactly do you mean with 'install'? Is there an automated
>   installation, like 'make install' on *NIX, for Windows? I only run
>
>     msdev "httpd-2.0\Apache.dsw" /MAKE "Apache - Win32 Release"
>
>   here and copy the binaries manually.

Ah ... That's probably the problem - modperl is looking for
certain header files in the MP_AP_PREFIX parent directory,
and if they're not found, the error you got would result.
What I do is open the top level Apache.dsw project file in
Visual Studio, and set the active configuration to
"InstallBin - Win32 Release". Building that will also
install everything into its expected place (with parent
\Apache2). I guess if you specify "InstallBin", rather
than "Apache", in the /MAKE of msdev, that the same thing
would result.

best regards,
randy


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@perl.apache.org
For additional commands, e-mail: dev-help@perl.apache.org


Mime
View raw message