perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chonger" <jch...@johncheng.dhs.org>
Subject Re: Problem compiling modperl-2
Date Sat, 08 Dec 2001 01:41:50 GMT
> > I have Apache-2.0.28 with the latest mod_perl 2 (downloaded as a tar.gz
from
> > perl.apache.org).
> >
> > I followed the instruction in the pod and installed Apache-2 fine. But
when
> > I tried to compile mod_perl I ran into this
> >
> > "AP_MODE_INIT" undeclared error.
>
> It may be that the Apache-2 and mod_perl-2 sources you have are
> out of sync with each other. Try getting the latest of both via
> cvs to see if this solves the problem.
>
> best regards,
> randy kobes

Right on the nose! I checked out the sources exactly as it described in the
pod
and recompiled, and it went flawlessly. Well, not flawlessly, but pretty
close.

In the latest Apache source, with-mpm=threaded is no longer an option, and
is replaced by with-mpm=worker. That is not reflected in the perl doc, but
I'm
sure is a quick change.

I am still curious why the AP_MODE_INIT error would occur. That file seems
to be come from ./xs/tables/current/Apache/ConstantsTable.pm. How is it
"missing." Is ConstantsTable.pm suppose to generate a .h file that is
included
somewhere?




---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@perl.apache.org
For additional commands, e-mail: dev-help@perl.apache.org


Mime
View raw message