perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chonger" <jch...@johncheng.dhs.org>
Subject Problem compiling modperl-2
Date Fri, 07 Dec 2001 22:37:27 GMT
A while I ago I tried to install mod_perl. Since it was for fun, I decided I
wanted to try mod_perl 2 with Apache-2 first.

I had problem compiling mod_perl with a threaded Apache 2 configuration. I
gave up and went to mod_perl with Apache 1.3 instead.

Now I'm trying to give another crack at it.

I have Apache-2.0.28 with the latest mod_perl 2 (downloaded as a tar.gz from
perl.apache.org).

I followed the instruction in the pod and installed Apache-2 fine. But when
I tried to compile mod_perl I ran into this

"AP_MODE_INIT" undeclared error.

Why is this error message coming up?

make[3]: Entering directory `/tmp/jcheng/modperl-2.0/xs/ModPerl/Const'
gcc -c -I/tmp/jcheng/modperl-2.0/src/modules/perl -I/tmp/jcheng/modperl-2.0/
xs -I/usr/local/apache2/include -D_REENTRANT -fno-strict-aliasing  -DMOD_PER
L -O3 -fomit-frame-pointer -Wall -mpentiumpro -march=pentiumpro -malign-func
tions=4 -funroll-loops -fexpensive-optimizations -funroll-all-loops   -DVERS
ION=\"0.01\" -DXS_VERSION=\"0.01\" -fpic -I/usr/local/perl/lib/5.6.1/i686-li
nux-thread-multi/CORE  modperl_constants.c
modperl_constants.c: In function `modperl_constants_lookup_apache':
modperl_constants.c:311: `AP_MODE_INIT' undeclared (first use in this
function)
modperl_constants.c:311: (Each undeclared identifier is reported only once
modperl_constants.c:311: for each function it appears in.)
make[3]: *** [modperl_constants.o] Error 1
make[3]: Leaving directory `/tmp/jcheng/modperl-2.0/xs/ModPerl/Const'
make[2]: *** [subdirs] Error 2
make[2]: Leaving directory `/tmp/jcheng/modperl-2.0/xs/ModPerl'
make[1]: *** [subdirs] Error 2
make[1]: Leaving directory `/tmp/jcheng/modperl-2.0/xs'
make: *** [subdirs] Error 2


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@perl.apache.org
For additional commands, e-mail: dev-help@perl.apache.org


Mime
View raw message