perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gerald Richter" <rich...@ecos.de>
Subject make test fails
Date Mon, 19 Nov 2001 08:30:30 GMT
Hi,

after haveing to work on other projects inbetween, I am back to mod_perl
development, especially I want to finish the xs building stuff, to get it
reincorporated into mod_perl.

To make sure my xs building stuff is doing the right thing, I want to have a
running make test first, so I can verify afterwards if it is still working.
Unfortunately currently it fails a few tests:

Failed Test     Status Wstat Total Fail  Failed  List of Failed
----------------------------------------------------------------------------
----
api/conn_rec.t                15   12  80.00%  4-15
api/module.t                  ??   ??       %  ??
modules/cgi.t                  6    1  16.67%  3
protocol/echo.t   29  7424     3    2  66.67%  2-3
1 test skipped.

In t/logs/error_log there is this

/opt/apache2/bin/httpd: error while loading shared libraries:
/usr/msrc/cvs/modperl-2.0/blib/arch/auto/Apache/Connection/Connection.so:
undefined symbol: mpxs_Apache__Connection_client_socket

I have seen a recent commit which moves this function, maybe something is
still broken here

Any ideas where to start searching ?

I use perl 5.6.1 and the preforked mpm

Gerald


-------------------------------------------------------------
Gerald Richter    ecos electronic communication services gmbh
Internetconnect * Webserver/-design/-datenbanken * Consulting

Post:       Tulpenstrasse 5         D-55276 Dienheim b. Mainz
E-Mail:     richter@ecos.de         Voice:    +49 6133 925131
WWW:        http://www.ecos.de      Fax:      +49 6133 925152
-------------------------------------------------------------



---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@perl.apache.org
For additional commands, e-mail: dev-help@perl.apache.org


Mime
View raw message