perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ken Williams" <...@forum.swarthmore.edu>
Subject Re: CVS build fails on Darwin
Date Wed, 18 Apr 2001 03:56:05 GMT
dougm@covalent.net (Doug MacEachern) wrote:
>
>to figure out what's missing, we'd need to see the link line that works
>for vanilla apache (should be similar to the above, but no perl stuff)

I tried building mod_perl again with current CVS, just to make sure, and
it was still broken.  Then I tried Apache, and it was broken now too!

Then I figured out what was going on.

Last time I tried this, I build Apache, then tried to build mod_perl. 
Before I did that, I had to install LWP.  LWP put a file called 'HEAD'
in /usr/bin/ , which blew away the file called 'head' (dang
case-insensitive filesystem...).  Apache uses 'head' during its
configuration process, so the build failed.

The upshot: current mod_perl CVS sources now build fine for me, and a
persistent riddle that poked its head up in various circumstances is now
solved.


  -------------------                            -------------------
  Ken Williams                             Last Bastion of Euclidity
  ken@forum.swarthmore.edu                            The Math Forum

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@perl.apache.org
For additional commands, e-mail: dev-help@perl.apache.org


Mime
View raw message