perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Geoffrey Young <gyo...@laserlink.net>
Subject RE: Apache::Module
Date Fri, 23 Feb 2001 18:53:11 GMT
well, this seemed to fix the problem:

--- Module.xs.old       Sun Jun  6 14:31:03 1999
+++ Module.xs   Fri Feb 23 13:45:36 2001
@@ -51,7 +51,8 @@
  */
 
 /* $Id: Module.xs,v 1.2 1998/10/23 00:13:57 dougm Exp $ */
-#include "modules/perl/mod_perl.h"
+#include "apache_inc.h"
+#include "mod_perl.h"
 
 typedef int (*handler_func) (request_rec *);
 extern module *top_module;

I'm not a C guy, so I dunno if this is the best way to do it.

At any rate, the Apache::Module examples all work for me now

--Geoff

> -----Original Message-----
> From: Geoffrey Young [mailto:gyoung@laserlink.net]
> Sent: Thursday, February 22, 2001 10:44 AM
> To: 'dev@perl.apache.org'
> Subject: Apache::Module
> 
> 
> hey all...
> 
> has anyone gotten Apache::Module to compile using perl >= 5.6?
> 
> I get _tons_ of parse errors, and I noticed that the package 
> hasn't been
> updated since 1999...
> 
> --Geoff
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@perl.apache.org
> For additional commands, e-mail: dev-help@perl.apache.org
> 

Mime
View raw message